HP OpenVMS Systems

ask the wizard
Content starts here

JSP and ODS-5 requirements?

» close window

The Question is:

Hi OVMS Wizard!
I have installed Tomcat 3.2.4 on OpenVMS/Alpha 7.3.1. I have only an ODS-2
file system so I cannot use more recent versions. I built the default jsp
examples and they all seem to work correctly, however, when I built my first
small jsp application, and tried to run it I got the following error:
org.apache.jasper.JasperException: Unable to rename class file
0002ejspclaimsResult_jsp_0.class to
 at org.apache.jasper.compiler.Compiler.compile(Compiler.java, Compiled
This looked like a permissions problem, so I  checked all my config files on
Tomcat (server.xml, tomcat.policy) and everything seems to be in order. Has
anyone seen this behavior?
Thanks in advance for your help!
Jim Jennis
Jim Jennis, Integration Architect
WRQ Consulting Services, Inc.
124 Old Forest Circle
Winchester, VA. 22602 USA.
Phone: +1-540-723-0157
FAX: +1-206-272-1394
WEB: http://www.wrq.com/
WRQ - Access. Integrate. Transform. Since 1981

The Answer is :

  As is usual with OpenVMS, you can use security auditing and security
  alarms to track access permissions and protection settings.
  Java and such assume ODS-5 semantics and capabilities, and the OpenVMS
  Wizard would tend to assume this case and not a file protection setting.

answer written or last revised on ( 30-DEC-2003 )

» close window