HP OpenVMS Systems

ask the wizard
Content starts here

Upgrades and Application Compatibility?

» close window

The Question is:

Will a selfmade application (written in C)
now working on AS4100, 2 proc, 1,5GB mem with
- OpenVMS 7.1 (with 2000 patch and patchkit 2)
- Networksoftware UCX for OVMS 4.1
- DECNet Plus for OVMS 7.1
- DECforms runtime 2.2
still works with the latest software versions
of the 4 above programs.
Or is it possible that the application in C has
to be rewritten.

The Answer is :

  Please see topics including (7555).
  For the differences between the OpenVMS releases, please see the
  OpenVMS release notes and new features manuals.
  Upward-compatibility of user-mode applications -- without requiring
  recompilation or relinking -- is a core goal of OpenVMS Engineering.
  Downward-compatibility -- the ability to run applications built
  on newer OpenVMS releases against older OpenVMS releases -- is not.
  Again, please see topics (7555), (3761), (5192), and (6829) for details.
  Related topics include (173), (866), (1052), (1171), (1904), (2738),
  (2932), (4336), (6049), (7019), etc.
  For some of the more common application coding bugs (and thus for some
  of the more common latent bugs), please see topics starting at (1661).

answer written or last revised on ( 24-NOV-2003 )

» close window