HP OpenVMS Systems

ask the wizard
Content starts here

Seeking Help With Ancient OpenVMS, DEC C?

» close window

The Question is:

Hi there,
I have an old VAX with open VMS 6.1 on it.
Is the DEC C compiler version 4.0 compatible to it and how do I install it?
(I only have TK50 media)
Thanks a lot!!

The Answer is :

  If you have to ask this question, you do not want to try this -- and
  no offense is intended here.  You are obviously inexperienced with
  OpenVMS, and long-outdated software configurations are not the most
  appropriate introduction to the environment.  Such configurations are
  also difficult to support, as ECOs and patches are no longer being
  C V6.4 is the current (and expected to be the final) version of the
  C compiler (direct descendent from DEC C V4.0) for OpenVMS VAX, and
  OpenVMS VAX V7.3 is the current OpenVMS release.
  OpenVMS VAX V6.1 was the first release of OpenVMS with DEC C support
  integrated, and DEC C V4.0 is the first release of DEC C.  Both this
  OpenVMS VAX version and this DEC C version have had all support removed
  long  ago -- much has changed and much has been updated.  The OpenVMS
  Wizard would recommend using more current (and supported) versions.
  If you do choose to try this, use the VMSINSTAL utility to load the
  DEC C installation kit, and please expect to immediately apply all
  mandatory ECO kits for OpenVMS VAX V6.1.
  For OpenVMS Hobbyist information and for pointers to the OpenVMS ECO
  download website and FTP servers, please see the OpenVMS Frequently
  Asked Questions (FAQ).

answer written or last revised on ( 19-MAY-2003 )

» close window