HP OpenVMS Systems

ask the wizard
Content starts here

Signal Handling and CMS?

» close window

The Question is:

I'm getting the following messages when a COBOL program calls CMS$SET_LIBRARY
 with a callback msg-routine that sends the message to a DECform:
-CC-F-NOMSG, Message Number 00B9B424
(in debug mode)
-UIL-F-NOMSG, Message Number 005A5424
(not in debug mode)
The CMS$SET_LIBRARY does return a successful code (CMS-S-LIBSET, library set),
 and I also noticed, via a debug session, that the routine first sent the
 expected message "%CMS-I-LIBIS, library is mydisk:[my_cms]" to DECform, then
 sent the above message whi
ch overwrote the first one.
When the same exact program is run under VAX V6.2, it only sends the expected
 message (%CMS-I-LIBIS, library is mydisk:[my_cms])to the DECform, which is
Questions: Any advise/suggestions?
Thank you!

The Answer is :

  These messages would appear to be junk -- the OpenVMS Wizard would
  initially assume that there are problems within the handling of the
  signal and mechanism arrays.
  Please familiarize yourself with the use and structure of signals
  and the signal and mechanism arrays used on OpenVMS; the calling
  standard and programming concepts documentation will be of central
  interest, and the system definition module CHFDEF will also be of
  some potential use.
  Please ensure you have current OpenVMS and DECwindows and CMS
  versions and ECOs installed.

answer written or last revised on ( 5-MAY-2003 )

» close window