HP OpenVMS Systems

ask the wizard
Content starts here

Mozilla Requires V7.2-1?

» close window

The Question is:

I have downloaded Mozilla V1.2Beta (and V1.1).
I note from the release notes at
 http://www.openvms.compaq.com/openvms/products/ips/mozilla_relnotes.html that
 these versions are not supported under VMS 7.1-2 but that they will
work. As far as I recall, this position is
confirmed when installing using PRODUCT INSTALL
(which completed without problems) however, I did not keep a record.
Unfortunately, they do not work. I receive the
following error message:
$ @sys$common:[mozilla]mozilla
Starting mozilla-bin...
%DCL-W-ACTIMAGE, error activating image CMA$TIS_SHR
-SYSTEM-F-SHRIDMISMAT, ident mismatch with shareable image
(I also get the same error when trying to unpack
the self-extracting zip archives but I cheated by using unzip instead.)
So I went to ftp.service.compaq.com looking for
a patch which updates CMA$TIS_SHR. The only
patch I could find that looks like it might be
suitable is VMS712_PTHREADS-V0300. However,
the readme says not to install this patch if
Compaq Multimedia Services for OpenVMS Alpha V2.0 (MMOV) is installed. (I have
 MMOV V2.2 installed).
So, my questions are:
1. Who should I tell that the mozilla release notes are wrong? This does not
 seem to be a mozilla bug and bugzilla seems inappropriate (not to mention not
 very useful from netscape 3.03).
2. Would installing VMS712_PTHREADS-V0300 help out with the ident mismatch
3. Would installing VMS712_PTHREADS-V0300 mess
up MMOV V2.2 or does it only relate to the IVP
in V2.0?

The Answer is :

  As should be no surprise, the OpenVMS Wizard will encourage you to
  upgrade your OpenVMS Alpha V7.1-2 release (first shipped in 1998) to
  a more current OpenVMS release.
  As of this writing, V7.2-2 or V7.3-1 would be the releases that the
  OpenVMS Wizard would upgrade to.  The OpenVMS Wizard would also
  encourage you to apply the mandatory ECO kits for the current OpenVMS
  release in use, whatever release that might be.
  It does appear that Mozilla was built against and does require newer
  RTLs than are presently loaded in your environment.  You might well be
  able to "ECO your way forward" sufficiently far enough for your own
  particular purposes here, but the supported minimum OpenVMS release
  for Mozilla is -- as stated -- OpenVMS Alpha V7.2-1.
  Here is the text:
  "Mozilla Supported Only on OpenVMS Version 7.2-1 and higher
  M0.9.5 is the last milestone release of Mozilla that is supported
  on OpenVMS Version 7.1-2 and earlier.  The current release of Mozilla
  for OpenVMS is supported only on OpenVMS Alpha Version 7.2-1 or
  Note: Although Mozilla can be installed and run on OpenVMS Version
  7.1-2 systems, the official end of support date for Version 7.1-2 is
  December 31, 2001. Customers are encouraged to upgrade to a later
  version of OpenVMS, such as Version 7.2-2 or Version 7.3-1."

answer written or last revised on ( 6-NOV-2002 )

» close window