HP OpenVMS Systems

ask the wizard
Content starts here

OpenVMS Platform Compatibility?

» close window

The Question is:

We currently have 2 Alpha machines, both running VMS 7.1.  One system is an
 Alpha 200 4/166, the other is an Alpha 200 4/233.  Is it possible to load an
 Image from the Alpha 166 system to the Alpha 233?  If so, is there anything
 'out of the ordinary that
needs to be done to accomplish this'?
Any assistance would be greatly appreciated.
Best regards
Cory Brace

The Answer is :

  This transfer should work just fine.
  OpenVMS is explicitly designed and explicitly intended to permit user-mode
  applications to be cross-compatible across platforms of the same version,
  ECO level and architecture, and also to permit user-mode applications to
  be upward-compatible across OpenVMS versions and ECOs.  No rebuilds, no
  recompilations, and no code changes are expected to be required.
  Applications that operate in privileged processor modes (eg: executive
  or kernel mode code, device drivers, etc) may be platform-specific or
  may require a rebuild or rework when OpenVMS is upgraded.  (Specifically
  on OpenVMS VAX V6.0 and later, user-mode and privileged-mode code should
  upgrade without changes.)
  Applications containing latent bugs or that are dependent on platform-
  specific features or on undocumented features may, of course, have some
  problems with upgrades or with different patforms.  (For one specific
  example of a latent error, please see the details and information in
  the 21264 directory of the OpenVMS Freeware V4.0 distribution.)

answer written or last revised on ( 6-SEP-2001 )

» close window