HP OpenVMS Systems

ask the wizard
Content starts here

Why minimum version requirements?

» close window

The Question is:

We are using OpenVMS V7.1-1H2 on AlphaServer 4100 5/600 machine. We want to
 install JAVA118
& Apache Web Server on our machine. The Apache
installation document mentions that minimum of
OpenVMS Alpha Version 7.1-2 & TCP/IP 5.0A or
higher is needed. It also mentions that if Open
VMS earlier than 7.1-2 is installed then following ECOs must be installed:
ALPACRT09_071 & ALPBASE02_071.
The Java 1.1.8 Patch Installation Patch also
suggest that OpenVMS V7.1-2 is required & patches VMS712_PTHREADS &
must be installed.
Kindly suggest what is the major difference between OpenVMS V7.1-1H2 & OpenVMS
 V7.1-2 & can
I install Apache HTTP server & Java 1.1.8 on
OpenVMS 7.1-1H2 & what ECOs must be installed?
If latest version of these packages can not be
installed but some earlier versions can be installed then which versions & from
 where can I get these? Also, kindly suggest if Apache needs
UCX 5.0A or it can run on V4.2 which is being
used by us currently.

The Answer is :

  Please recognize that a few updates and a few changes have been made
  to OpenVMS Alpha V7.1, OpenVMS Alpha V7.1-1H1, and OpenVMS Alpha
  V7.1-1H2 to create OpenVMS Alpha V7.1-2.
  Please also recognize that OpenVMS Engineering does not establish the
  minimum version requirements on whim, these requirements are established
  to ensure that the environment that Compaq OpenVMS Engineering provides
  for your software and your application and system configuration can be
  tested and thus can be supported.
  In most cases, OpenVMS Engineering or other Compaq groups will establish
  a baseline of ECOs and version support for the purpose of permitting
  product testing and support, and for baseline requirements of the
  product environment -- without a baseline, the testing permutations
  become unmanagable, and the (lack of) required features (eg: APIs
  missing from older releases) restrict capabilities and/or increase the
  product engineering for conditionalization or back-porting of the
  environment.  In cases where the ECO kits and versions are specified
  solely for purposes of restricting the testing and support requirements,
  you may or may not be able to operate as expected outside of the specified
  software configuration.
  In the specific case of Java and CSWS, (Compaq Secure Web Server; a web
  server based on Apache), OpenVMS Engineering has identified specific
  prerequisite updates and product versions, updates and versions that
  are necessary for the correct operation of the environment.   In most
  cases, Compaq OpenVMS Engineering does not differentiate the reason(s)
  for the prerequisites.
  Also note the potential for you to spend time and effort resolving
  various problems that have already been fixed in existing and available
  ECO kits.  Some of these problems can be obvious, and some quite subtle.
  In the particular case of V7.1, V7.1-1H1 and V7.1-1H2, the following
  OpenVMS ECO kits applicable to V7.1, V7.1-1H1 and/or V7.1-1H2 and are
  incorporated into OpenVMS Alpha V7.1-2 -- these ECO kits do not need
  to be installed on your system if you should choose to upgrade to the
  OpenVMS Alpha V7.1-2 release:
     ALPACRT07_071, ALPACRT08_071, ALPAUDS01_071, ALPBACK04_071,
     ALPBASE02_071, ALPBASR01_071, ALPBASR02_071, ALPDISM01_071,
     ALPCLD01_071, ALPCLIU02_071, ALPCLIU03_071, ALPCLIU04_071,
     ALPCPU002_071, ALPCPU0C04_071, ALPCPU1101_071, ALPCPU1602_071,
     ALPCPU1603_071, ALPCPU1A01_071, ALPCPU1B01_071, ALPCPU1E01_071,
     ALPCPU1E02_071, ALPCPU1E03_071, ALPCPU2001_071, ALPDCL01_071,
     ALPDDTM01_071, ALPDEBU02_071, ALPDPML01_071, ALPDRIV12_071,
     ALPDUP01_071, ALPF11X06_071, ALPHYPR01_071, ALPIPC01_071,
     ALPINIT01_071, ALPLIB07_071, ALPLIBR08_071, ALPLOGI07_071,
     ALPLAD01_071, ALPLAN01_H1071, ALPLAT02_071, ALPLBR01_071,
     ALPLOAD01_071, ALPLOGI07_071, ALPMAIL03_071, ALPMC01_071,
     ALPMOUN07_071, ALPMSCP01_071, ALPMOUN04_071, ALPMTAA01_071,
     ALPNT01_071, ALPOPCO01_071, ALPPORTS01_071, ALPPPPD01_071,
     ALPPTHR02_071, ALPQMAN02_071, ALPRMS03_071, ALPRTPA01_071,
     ALPSCSI05_071, ALPSHAD06_071, ALPSYS20_071, ALPSYS011_071,
     ALPSYSI01_071, ALPTTDR01_071, ALPTNT01_071, ALPTRAC01_071,
     ALPVERI02_071, ALPVKCT02_071, and ALPY2K01_071.  Or later.
  If you choose to apply these kits manually, you must install these kits
  in the correct order (not alphabetical!), and you must also reboot after
  the installation of various (specific) ECO kits.  There are also ECO
  kits that are mandatory for OpenVMS V7.1-2, and specifically kits that
  are NOT available for OpenVMS Alpha V7.1, V7.1-1H1 and/or V7.1-1H2.
  If you choose NOT to apply these kits (or upgrade to V7.1-2 or later,
  well, the OpenVMS Wizard would then encourage you to reconsider.
  As part of OpenVMS Alpha V7.1-2, we also provided a new installation
  mechanism (PCSI) for ECO kits, and we switched from VMSINSTAL to PCSI
  for SHIP kits.
  In other words, please feel free to try running in the configuration
  you cite, and please let the OpenVMS Wizard know if the particular
  configuration works for you.  But please expect to be required to
  duplicate any problem(s) you might encounter in a supported
  configuration, should you wish Compaq to provide a resolution.
  The OpenVMS FAQ contains information on minimum supported OpenVMS
  versions for various platfomrs, on layered product version requirements
  for recent OpenVMS versions, and pointers to the information and the
  requirements (and prerequisites) for CSWS and Java.

answer written or last revised on ( 29-MAY-2001 )

» close window