HP OpenVMS Systems

ask the wizard
Content starts here

Fortran DECnet task-to-task error?

» close window

The Question is:

I have a program that runs on other Alpha's
that doesn't work on this Alpha.  It connects
via mailboxes and the IOSB(1) is returning
SS$CHANINTLK.  The calls are:
NCB = (IREMOTE_HOST))//'::"0='//IREMOTE_PORT//'/'//
        1       char(0)//char(0)//char(12)//CPID//'    "'
        NCB_D(2) = %LOC(NCB)
        NCB_D(1) = LEN(NCB)
        1                IOSB,,,,%RE(NCB_D),,,,)
all these calls return success, but the IOSB(1)
on the qiow contains 652 - SS$CHANINTLK
Help !!

The Answer is :

  Please check the error codes again:
$ exit 76
%SYSTEM-F-CHANINTLK, channel usage interlocked
$ exit 652
%SYSTEM-F-NOSUCHNODE, remote node is unknown
  And please check the process quotas and system parameter differences,
  as the program (unfortunately) trusts the default system parameter
  settings for its mailbox operations -- the explicit specification of
  the arguments for the required mailbox size and the mailbox buffer
  quota are recommended for every $crembx call, as inconsistent behaviour
  can otherwise arise as the program is moved to other systems or as
  system parameters are altered.
  Also please check your specification of $assign and of $crembx, as it
  appears that some of the arguments are missing.  (Unlike the behaviour
  permitted with various RTL services, you will not want to omit arguments
  from system services.)
  Once these have been addressed, please provide a complete (concise,
  standalone) program example to the folks at the Compaq Customer Support
  Center, and this will be investigated.

answer written or last revised on ( 3-SEP-2000 )

» close window