HP OpenVMS Systems

ask the wizard
Content starts here

Upward and Downward Compatibility?

» close window

The Question is:

Where can I get information on the difference between OPenVMS Alpha 7.1 and
If V7.2-1 installed, it is compatible with software (BASIC) compiled and linked
 on 7.1

The Answer is :

  For the differences between the releases, please see the OpenVMS
  release notes and new features manuals.
  Upward-compatibility is a general goal of OpenVMS.
  Downward-compatibility is not.
  There are some (unsupported) techniques that can sometimes permit
  applications linked on newer releases to operate on older
  releases, but as testing in the target environment is generally
  recommended and generally beneficial, why not simply build the
  image(s) in the target environment?
  Please see topics (3761), (5192), and (6829).
  Related topics include (173), (866), (1052), (1171), (1904), (2738),
  (2932), (4336), and (6049).

answer written or last revised on ( 11-OCT-2001 )

» close window