HP OpenVMS Systems

ask the wizard
Content starts here

Layered Product Compatibility?

» close window

The Question is:

Where can I find what version of a software compiler ( e.g. vaxbasic) is
 compatible with each version of openvms? I'm migrating from one version of
 OpenVMS to the next and can't find what version I need.

The Answer is :

  With any compiler as with most other products, the best advice is to
  always use the latest version.  The only issue is the minimum version
  of the operating system required by the particular version of the
  compiler.  This information is listed in the installation guide for
  the compiler.
  Compilers, normally being comprised of user-mode code, will obey the
  normal upwards-compatibility rules for OpenVMS.  That is, if the code
  runs on a particular version of OpenVMS, the code is generally expected
  to operate on all later OpenVMS versions.
  The OpenVMS Wizard would recommend that you find the latest version of
  the compiler you're interested in and check the installation guide. If it
  requires a higher version of the operating system than you are currently
  running, then you should upgrade your operating system first!
  For general information on products and versions, please see the OpenVMS
  Software Rollout report:

answer written or last revised on ( 3-APR-2000 )

» close window