HP OpenVMS Systems

ask the wizard
Content starts here

DECserver and formfeed processing on printers?

» close window

The Question is:

I am trying to print HCFA forms on to Okidata 320 Turbo printers.  It prints
a page then spits out a blank and prints another page and so on.  After a
few months of off and on testing I found that the terminal server the
printer was connected to was the d
ifference.  Only the Dec Servers are having this problem.  In the job to
print there are <FF> codes.  The other term servers we use see this code and
make sure the next page is there. The Dec Servers advance a full page.  I
have entered a work order with
Compaq asking for the possibilty of a firmware upgrade.  This happens mainly
on our DS700 and DS90m.  I have changed the print queue over a million times
as well as the form. I have used the reset modules and even tried to make my
own, to no success.  Is
there anything else I can do the queue or the form to asure the <FF> code
will not advance a full page?  I am using an Alpha 4100, OpenVMS 7.1,  and
TCPIP 5.0A.  I have also reveiwed the "Ask the Wizard" page looking for the
answer and did not find one.
I do have the escape codes for the printer and a print out of the SMGTERMS.
Do you by chance already have an escape code combination that will do this?
Thanks for you help.

The Answer is :

  The formfeed (FF) character explicitly and intentionally advances the
  form in the printer -- you appear to be encountering a formfeed near
  or at the top of a form, or you have an extra formfeed, or you are
  seeing the insertion of multiple linefeed characters in place of a
  Given your comments, this does not initially appear to be an OpenVMS
  problem (and thus outside the domain of the OpenVMS Wizard), as this
  appears to be a problem with or a setting in the terminal server(s).
  Please contact the Compaq Customer Support Center for assistance in
  troubleshooting this.  This could potentially be a setting within the
  DECserver that controls the hardware formfeed on the DECserver port,
  or it could be the SET TERMINAL /[NO]FORM setting on the OpenVMS
  terminal line, it could be a problem with the printer, it could be a
  page length problem in the queue or the SYS$LP_LINES logical name, it
  could be the end-of-job or burst or flag page setting on the queue, or
  it could be a problem elsewhere in the particular printing environment.
  Though if this occurs *only* with DECserver terminal servers, then this
  is less likely something in the OpenVMS host environment -- rather, this
  would then appear to be specific to the setting of the terminal server.
  (Thus, check the page settings in the terminal server.)
  Certain tractor-feed printers can also be set to automatically advance
  the form to where it can be easily accessed when the print run ends.

answer written or last revised on ( 9-DEC-1999 )

» close window