HP OpenVMS Systems

Ask the Wizard

HP OpenVMS Systems

OpenVMS information

» What's new on our site
» Upcoming events
» Configuration and buying assistance
» Send us your comments

HP OpenVMS systems

» OpenVMS software
» Supported Servers
» OpenVMS virtualization
» OpenVMS solutions and partners
» OpenVMS success stories
» OpenVMS service and support
» OpenVMS resources and information
» OpenVMS documentation
» Education and training

Quick Links

» Non-javascript page
» Ask the Wizard

Test Drive OpenVMS

» OpenVMS I64 test drive
» Java test drive

Other information resources available to you include:

» OpenVMS freeware
» ECO kits, software and hardware support, prior version support
» Alpha SRM, ARC, and AlphaBIOS firmware updates
» ENCOMPASS - HP user group
» OpenVMS software downloads, OpenVMS freeware CD-ROM
» OpenVMS firmware locations
» DECconnect passive adaptor charts
» Cables reference guide
» MicroVAX console commands
» OpenVMS student research

Select a topic below to see Questions Frequently Asked by partners

» Using the online documentation library(installing BNU from the asap SDK)
» Global sections(how to create and use.)
» xx$CREATE_BUFOBJ system service(usage)
» Ethernet address(methods of determination)
» Shareable images(cookbook approach to creating one)
» Sharing data/code at absolute addresses(a guide with examples)
» Determining the Alpha microprocessor
» Using GETSYI to get hardware status

Evolving business value

» Business Systems Evolution
» AlphaServer systems transition planning
» Alpha RetainTrust program

Related links

» HP Integrity servers
» HP Alpha systems
» HP storage
» HP software
» HP products and services
» HP solutions
» HP support
disaster proof
HP Integrity server animation
HP Integrity server animation
Content starts here

Ask the Wizard Questions

DECwindows: ATI Mach64 on V6.2

The Question is:

I am trying to get an ATI Mach64 graphics adaptor to work
on my Alpha Server 2100 (VME).  When I run sys_exer at the
boot prompt it appears to work just fine (i.e., I get a
continual string of "Digital" repeated across the screen).
However once the machine boots the ATI attached terminal
does not display the expected login screen.  It blacks
out about 1/4 of the screen and the rest has the blue
background that was there from the VGA sys_exer tests.

I called ATI and they said that their card works just fine
in the Alpha Server 2100 without adjusting any of the
jumpers on the card.

I got (via my local DEC guy) the ECO patch AXPGUP01_062 so
that the ATI Mach64 driver would be there.  It installed
without reporting any problems.

I reran AUTOGEN and still it did not work.

I look in the DECW$SERVER_0_ERROR.LOG and it does not say
anything bad that I can see.  These are the last few lines
from the log file:
------------------begin text ------------------
ati64vmsScreenInit:  Init the common VGA screen
VGAVMS_InitScreenCommon: Init the Screen structure
 cputype = 2 (2 = EV4, 5 = EV5)
ati64vmsScreenInit:  Using EV4 routines
ati64vmsScreenInit:  Fifo low-water mark value: 4
ati64vmsScreenInit:  Init hardware
atiHWInit:           Unsupported chip type found = type 0
atiHWInit:           Chip Rev    0
atiHWInit:           Unsupported DAC found = type 0, assuming 6-bit DAC
atiHWInit:           6-bit DAC (RGBShift = 10)
ati64vmsScreenInit:  Cursor Setup, DAC type = 0
ati64vmsScreenInit:  Call cfbCreateDefColormap
ati64vmsScreenInit:  Init the backing store
ati64vmsScreenInit:  Exit from init with success
DEC-XTRAP:  AddExtension assigned Major Opcode '137'
DEC-XTRAP:  Vers. 3.3-0 successfully loaded
MultibufferExtensionInit: Drawlib not loaded.
11-APR-1996 18:21:48.4 Calling the dispatcher...
--------------- end of text ---------------

Any thoughts?

Thank you for your help.

The Answer is:

         1. Configure the system firmware to recognize the MACH64 option.

         2. Install the appropriate patch, if OpenVMS version is pre-7.0.

         3. Make sure SYSMAN is using the proper prefix when searching for
            the file SYS$LIBRARY:DECW$ICBM.EXE.  Note: ICBM stands for
            IOGEN Configuration Building Module

    Verify you have read:

    "ATI MACH64-GX (ISA) Graphics Option Owners Manual", October 1995,
    (EK-ATIMC-OG. A01).

    "AlphaStation 200 4/100 MACH64 [PCI] Graphics Accelerator Installation
    Guide", February 1995, (EK-PCDGA-DI. A01).