HP OpenVMS Systems

Ask the Wizard

HP OpenVMS Systems

OpenVMS information

» What's new on our site
» Upcoming events
» Configuration and buying assistance
» Send us your comments

HP OpenVMS systems

» OpenVMS software
» Supported Servers
» OpenVMS virtualization
» OpenVMS solutions and partners
» OpenVMS success stories
» OpenVMS service and support
» OpenVMS resources and information
» OpenVMS documentation
» Education and training

Quick Links

» Non-javascript page
» Ask the Wizard

Test Drive OpenVMS

» OpenVMS I64 test drive
» Java test drive

Other information resources available to you include:

» OpenVMS freeware
» ECO kits, software and hardware support, prior version support
» Alpha SRM, ARC, and AlphaBIOS firmware updates
» ENCOMPASS - HP user group
» OpenVMS software downloads, OpenVMS freeware CD-ROM
» OpenVMS firmware locations
» DECconnect passive adaptor charts
» Cables reference guide
» MicroVAX console commands
» OpenVMS student research

Select a topic below to see Questions Frequently Asked by partners

» Using the online documentation library(installing BNU from the asap SDK)
» Global sections(how to create and use.)
» xx$CREATE_BUFOBJ system service(usage)
» Ethernet address(methods of determination)
» Shareable images(cookbook approach to creating one)
» Sharing data/code at absolute addresses(a guide with examples)
» Determining the Alpha microprocessor
» Using GETSYI to get hardware status

Evolving business value

» Business Systems Evolution
» AlphaServer systems transition planning
» Alpha RetainTrust program

Related links

» HP Integrity servers
» HP Alpha systems
» HP storage
» HP software
» HP products and services
» HP solutions
» HP support
disaster proof
HP Integrity server animation
HP Integrity server animation
Content starts here

Ask the Wizard Questions

TT Driver: Terminal flushing

The Question is:


    (OpenVMS version 1.51h)I have an application that involves a VMS
    computer talking to (commanding) micro-controllers via dedicated serial
    lines. I upgraded from a uVAX II with a serial card to an Alpha
    3000-300L with Lantronix terminal server using LAT.  After that
    flushing the typeahead buffer of these serial ports (which I do after
    errors) stopped working. The command executes but no data is removed
    from the typeahead buffer. I have read the current OpenVMS manuals the
    the necessary QIO calls do not app ear to have changed (and appear to
    be valid for LAT connections). What is wrong? My technique is as
    follows (but alternate techniques that still work would be welcome!):

    	code = io$_ReadVBlk .OR. io$m_Timed .OR. io$m_Purge
    	status =  sys$QIO W ( 2 , %val (Chan_num), %val (code), iostat, , ,
    	2                      %ref (dumchar), %val (1), %val (0), , , )

The Answer is:

    	I know of no reason why the flush would not have actually worked.
    The timing using LAT is very different from direct connected terminals.
    It is quite possible that the data was not in the type-ahead buffer
    when the flush was requested.

    	Other than suggesting that he while debugging check that the data
    he is expecting to flush in in the type-ahead buffer to confirm that it
    was flushed I cannot suggest much.