HP OpenVMS Systems

Content starts here CSWS_PERL for HP Secure Web Server for OpenVMS

CSWS_PERL for HP Secure Web Server
for OpenVMS (based on Apache)

Installation Guide and Release Notes

November 2005

CSWS_PERL Version 2.1 for OpenVMS Alpha
CPQ-AXPVMS-CSWS_PERL-V0201--1.PCSI_SFX_AXPEXE

CSWS_PERL Version 2.1 for OpenVMS I64
HP-I64VMS-CSWS_PERL-V0201--1.PCSI_SFX_I64EXE

Contents

What's New
Software Prerequisites
Documentation
Downloading the Kit
Expanding the Kit
Before You Begin the Installation
Installing CSWS_PERL for OpenVMS
Post-Installation Task
Removing CSWS_PERL for OpenVMS
Release Notes

What's New

Two new kits for CSWS_PERL Version 2.1 are now available - one for OpenVMS I64 Version 8.2 and higher, and one for OpenVMS Alpha 7.3-2 and higher.

CSWS_PERL Version 2.1 is intended to work with the Secure Web Server Version 2.1 and higher only. (Use CSWS_PERL Version 2.0 and Perl Version 5.6-1 ECO 3 with the Secure Web Server Version 2.0. Use CSWS_PERL Version 1.1-1 and Version Perl 5.6-1 with the Secure Web Server Version 1.3-1.)

CSWS_PERL Version 2.1 is based on mod_perl 2.0.0-RC4 (identified as 1.999.21 by /server-info). See http://perl.apache.org/ for more information.

Software Prerequisites

The CSWS_PERL for OpenVMS kit requires that the following software is installed before you install CSWS_PERL:

         OpenVMS Alpha Version 7.3-2 or higher
- or -
OpenVMS I64 Version 8.2 or higher


         Secure Web Server Version 2.1 and higher for OpenVMS


         Perl Version 5.8.6 (or higher) for OpenVMS

Documentation

For more information about mod_perl, see the Apache/Perl Integration Project.

See the Perl for OpenVMS Installation Guide and Release Notes for information about running Perl.

Downloading the Kit

» Download CSWS_PERL Version 2.1 for HP Secure Web Server for OpenVMS Alpha
» Download CSWS_PERL Version 2.1 for HP Secure Web Server for OpenVMS I64

Also available for download are earlier versions of CSWS_PERL:

» Download CSWS_PERL Version 1.1 for HP Secure Web Server for OpenVMS Alpha
» Download CSWS_PERL Version 1.1-1 for HP Secure Web Server for OpenVMS I64

See the CSWS_PERL Version 2.0 for OpenVMS Installation Guide and Release Notes to download CSWS_PERL Version 2.0.

Expanding the Kit

To expand the CSWS_PERL for OpenVMS self-extracting file enter one of the following commands, depending on the kit you download:

$ RUN CPQ-AXPVMS-CSWS_PERL-V0201--1.PCSI_SFX_AXPEXE ! for Alpha
$ RUN HP-I64VMS-CSWS_PERL-V0201--1.PCSI_SFX_I64EXE ! for I64

The system expands the file and names the decompressed file CPQ-AXPVMS-CSWS_PERL-V0201--1.PCSI
or HP-I64VMS-CSWS_PERL-V0201--1.PCSI. Do not rename this file.

Before You Begin the Installation

Before you begin the installation of CSWS_PERL, do the following:

         Add logical definitions for Perl

You must define the logical PERL_ROOT before you install or remove the CSWS_PERL kit. The CSWS_PERL kit installs several files that extend the capabilities of Perl. The PERL_ROOT logical must be available to CSWS_PERL in order to add and remove those files.

If you are running multiple versions of Perl, make sure that the Secure Web Server can only see the version of Perl that has been modified to work with the Secure Web Server. You can do this by adding the logical definitions to LOGIN.COM for the account running the Secure Web Server. Note that if the logicals are defined this way, they must be JOB logicals so that they can be passed to any subprocesses.

To define PERL_ROOT and PERLSHR, enter the following commands:

$ DEFINE/JOB PERL_ROOT DKB100:[PERL5_8_6.]/TRANS=CONC
$ DEFINE/JOB PERLSHR PERL_ROOT:[000000]PERLSHR.EXE

Installing CSWS_PERL for OpenVMS

To install the CSWS_PERL for the Secure Web Server for OpenVMS kit, enter the following command.

Note: You must install the CSWS_PERL kit into the same device and directory where you installed the Secure Web Server for OpenVMS.

For example:

$ SHOW LOGICAL APACHE$ROOT
 "APACHE$ROOT" = "DISK1:[WEB_SERVER.APACHE.SPECIFIC.hostname.]
 = "APACHE$COMMON:"
1 "APACHE$COMMON" = "DISK1:[WEB_SERVER.APACHE.]
 
$ PRODUCT INSTALL CSWS_PERL/DESTINATION=DISK1:[WEB_SERVER]

For a description of the features you can request with the PRODUCT INSTALL command when starting an installation such as running the IVP, purging files, and configuring the installation, see the POLYCENTER Software Installation Utility User's Guide.

As the installation procedure progresses, the system displays information similar to the following:

 The following product has been selected:
 CPQ AXPVMS CSWS_PERL V2.1 Layered Product
 
 Do you want to continue? [YES]
 
 Configuration phase starting ...
 
You will be asked to choose options, if any, for each selected product and 
for any products that may be installed to satisfy software dependency requirements.
 
 CPQ AXPVMS CSWS_PERL V2.1
 
 Hewlett-Packard Development Company, L.P.
 
 * This product does not have any configuration options.
 
 Execution phase starting ...
 
 The following product will be installed to destination:
 CPQ AXPVMS CSWS_PERL V2.1 DISK1:[WEB_SERVER.]
 
 Portion done: 0%..20%..30%..40%..80%..100%
 
 The following product has been installed:
 CPQ AXPVMS CSWS_PERL V2.1 Layered Product
 
 CPQ AXPVMS CSWS_PERL V2.1
 
 Post-installation tasks are required for MOD_PERL for OpenVMS.
 
 The release notes give detailed directions. This information
 is a brief checklist.
 
 This installation modifies APACHE$ROOT:[CONF]HTTPD.CONF to
 
enable MOD_PERL. Check HTTPD.CONF for accuracy. The line
 
"Include /apache$root/conf/mod_perl.conf" should be the only
 difference. Also study the MOD_PERL configuration file
 (APACHE$ROOT:[CONF]MOD_PERL.CONF) 
for options required for your
 site. 
The APACHE::Registry module is enabled by default and
 the location "/perl" is defined to access it.
 
 The Apache server must be shutdown and restarted to make these
 changes to the HTTPD.CONF file take place. 
Test that MOD_PERL
 is working by accessing the sample script from a browser:
 
 
http://your_web_server_host/perl/perl_rules.pl
 
 Thank you for using the Secure Web Server for OpenVMS.

Post-Installation Task

         Review MOD_PERL.CONF

Review the APACHE$COMMON:[CONF]MOD_PERL.CONF configuration file to be sure it enables all of the features required for your site.

Removing CSWS_PERL for the Secure Web Server for OpenVMS

You can remove the CSWS_PERL kit by using the PRODUCT REMOVE command. The Secure Web Server must be shut down before you remove CSWS_PERL.

To remove CSWS_PERL, enter the following commands:

 $ SET DEF APACHE$ROOT:[000000]
 $ @SYS$STARTUP:APACHE$SHUTDOWN
 $ PRODUCT REMOVE CSWS_PERL

The PRODUCT REMOVE command removes all files created by this installation. It also attempts to remove the directories defined by this installation. The removal also deletes the reference to the MOD_PERL.CONF configuration file from the HTTPD.CONF file.

Release Notes

This section contains notes on the current release of CSWS_PERL.

         Extended filename support not included

This version of CSWS_PERL does not include support for extended filenames. Use of extended filenames in mod_perl directives or within Perl scripts may cause unpredictable results. HP recommends that you convert any special characters within file and directory names to a suitable ODS-2 supportable character, such as the underscore ("_") character.

         Order of installing optional modules

Previous CSWS_PERL kits required that you install CSWS_PERL before installing other optional kits, if you were installing the kits on the same system. This restriction has been removed. You can install CSWS_PERL before or after CSWS_PHP and CSWS_JAVA, or you can install one without the others.

However, you must install and configure the Secure Web Server for OpenVMS and Perl for OpenVMS before you install CSWS_PERL.

         File protections of Perl scripts

When you create a Perl script, make sure it is world readable and world executable.

For example:

$ SET FILE/PROTECTION=W:RE MYSCRIPT.PL

         Tracking versions of CSWS_PERL and Perl

The CSWS_PERL and Perl kits are tightly connected. Future versions of Perl or CSWS_PERL may not interact correctly across version numbers. This release of CSWS_PERL works with Perl V5.8.6.

         Shareable image mismatch

If you are pointing at the wrong version of Perl, an ident mismatch occurs and the following error appears in the log file.

Syntax error on line 207 of /apache$root/conf/httpd.conf:
Can't locate API module structure `perl_module' in file
/apache$root/mod_perl.exe:
%LIB-E-ACTIMAGE, error activating image !AS
 
 
 
 
 

 

» Return to the Secure Web Server for OpenVMS home page