HP OpenVMS Systems

Daylight Saving Time changes

HP OpenVMS Systems

OpenVMS information

» What's new on our site
» Upcoming events
» Configuration and buying assistance
» Send us your comments

HP OpenVMS systems

» OpenVMS software
» Supported Servers
» OpenVMS virtualization
» OpenVMS solutions and partners
» OpenVMS success stories
» OpenVMS service and support
» OpenVMS resources and information
» OpenVMS documentation
» Education and training

Evolving business value

» Business Systems Evolution
» AlphaServer systems transition planning
» Alpha RetainTrust program

Related links

» HP Integrity servers
» HP Alpha systems
» HP storage
» HP software
» HP products and services
» HP solutions
» HP support
disaster proof
HP Integrity server animation
HP Integrity server animation
Content starts here

Upcoming changes to Daylight Saving Time in the U.S.

The Energy Policy Act of 2005 will change the start and end times for Daylight Saving Time (DST) in the U.S. starting in 2007. Beginning in 2007, DST will start on the second Sunday in March (instead of the current first Sunday in April). DST will end on the first Sunday in November (instead of the current last Sunday in October). In addition, a number of counties in Indiana have changed in 2006 from the Eastern U.S. time zone to the Central U.S. time zone.

To meet this need, HP provided updated time zone information for the world (as of March 2006 tzdata2005m) in OpenVMS version 8.3. NOTE: OpenVMS version 8.3 includes support for all Canadian time zones except for the Canadian Mountain and Pacific time zones; support for these time zones is available by applying the version 8.3 patch kits shown below.

Time-zone changes have also been backported to prior OpenVMS versions as shown in the table below. All of the backport kits listed here include support for all Canadian time zones.

OpenVMS version Backport kit
OpenVMS VAX version 6.2 VAXTZ01_062.A-DCX_VAXEXE
(See NOTE below)
OpenVMS VAX version 7.3 VAXTZ02_073
(See NOTE below)
OpenVMS Alpha version 6.2 ALPTZ01_062.A-DCX_AXPEXE
(See NOTE below)
OpenVMS Alpha version 7.3-2 VMS732_TZ-V0300
OpenVMS Alpha version 8.2 VMS82A_TZ-V0200
OpenVMS Alpha version 8.3 VMS83A_TZ-V0100
OpenVMS for HP Integrity servers version 8.2 VMS82I_TZ-V0200
OpenVMS for HP Integrity servers version 8.2-1 VMS821I_TZ-V0200
OpenVMS for HP Integrity servers version 8.3 VMS831I_TZ-V0100
NOTE: For VAX and Alpha version 6.2 systems, this patch is only needed if DECnet/OSI (DECnet Phase V) is in use. For all versions newer than v6.2, the patch should be applied regardless of DECnet version, and even if DECnet is not in use.

All of the patch kits listed above are available from the HP IT Resource Center (ITRC).

VMS version 5.5-2 requires that you modify the system time manually. For more information, please refer to the VMS version 5.5-2 instructions (pdf).

There are other methods for setting the time on systems in addition to the automated change. Starting with OpenVMS version 7.3-1, in SYS$MANAGER there is a function UTC$TIME_SETUP that works with the time-zone files and allows system managers to set the system time and time zone. Additional information is available in the SYS$EXAMPLES file DAYLIGHT_SAVINGS.COM for making manual time change adjustments.

For additional information about Daylight Saving Time, please refer to the HP IT Resource Center (ITRC).


If you use ACRTL on OpenVMS version 7.3-2, you must apply the ACRTL patch kit VMS732_ACRTL-V0300 to your version 7.3-2 system (in addition to applying the OpenVMS timezone patch kit VMS732_TZ-V0300). For other versions of OpenVMS, please note the following:

  • Timezone patches for OpenVMS versions prior to version 7.3-2 do not require any corresponding ACRTL changes.
  • OpenVMS operating system versions more recent than version 7.3-2 include the ACRTL changes in the initial operating system release and do not require additional ACRTL patches.

Distributed Computing Environment (DCE)

DCE is qualified for USDST 2007 changes with the OpenVMS timezone patches on all versions of OpenVMS listed in the table above, except for OpenVMS version 6.2 on both VAX and Alpha. If you are running OpenVMS version 6.2 VAX or Alpha and require the version 6.2 DCE timezone patch, please contact your HP support representative or your authorized reseller.

New DST rules may require HP Java software updates

Due to the 2007 Daylight Saving Time rules changes, updates may be needed for HP Java software. HP recommends utilizing the latest HP Java JDK/JRE update release as the preferred vehicle for delivering timezone data updates, product improvements, and security fixes. Please refer to the HP Java website for more information about Java software releases that support Daylight Saving Time.