HP OpenVMS Systems Documentation

Content starts here
HP Pay per use (PPU) User's Guide for versions 8.x > Chapter 2 Understanding PPU Requirements

PPU Software Requirements

  Table of Contents

  Index

PPU systems are required to run the PPU software on every partition in the complex. These partitions report information to the utility meter (located on your network). If the PPU software on your PPU system does not send usage reports, your system’s core utilization may be assumed to be at 100 percent. In an HPVM environment, PPU is installed and configured only on the host, not on the guest Virtual Machines.

Required Version of Utility Meter Software

IMPORTANT: The PPU 8.x software is inoperable if the Utility Meter software is not version 7.3 (or higher).

HP-UX 11i v1 Requirements

For PPU Versions 8.x on
HP-UX 11i v1

The following software is required for PPU 8.x on HP-UX 11i v1:

  • HP-UX 11i v1 June 2006 update, or later

  • PPU software bundle T2351AA (version B.11.11.08.00.01) located on the following HP web site (search for “T2351AA”):
    http://www.hp.com/go/softwaredepot

  • WBEM software bundle B8465BA (version A.01.05 or higher)

  • NParProvider bundle (version B.12.01.06.01 or higher, available from the OE)

  • The kernel configuration must include the diag2 module

  • Network access to utility meter software version 7.3 (or higher)

NOTE: On hp 9000 Superdome servers, the Utility subsystem firmware must be 6.40 or greater. PPU is not supported on versions prior to 6.40. The Utility firmware revision is displayed in two places by the Management Processor (MP). To determine your version, look at the main menu when you first log in to the MP, or type CM at the main menu to display the command menu, then HE for help.On hp 9000 servers rp8400 and rp7410, PDHC firmware version 2.03 or greater is required.

Your PPU system is shipped with the correct version of HP-UX and the PPU software bundle. If your system’s operating system is reinstalled with Ignite-UX, ensure that the correct version of HP-UX is used and the PPU software is reinstalled. See “Getting Started” for details.

Required Patches for PPU on HP-UX 11i v1

Because the PPU software can activate and deactivate cores, the following patches are required for PPU 8.x systems running HP-UX 11i v1:

  • PHKL_22987: S700_800 11.11 pstat() patch

  • PHKL_23154: S700_800 11.11 dflush() patch

  • PHKL_25218: S700_800 11.11 PDC Call retry, PDC_SCSI_PARMS, iCOD hang fix

  • PHKL_26232: S700_800 11.11 Psets Enablement patch,
    FSS iCOD patch

  • PHCO_24396: S700_800 11.11 /etc/default/tz patch

  • PHCO_24477: S700_800 11.11 sar(1M) patch

  • PHCO_29832: S700_800 11.11 reboot(1M) patch

  • PHCO_29833: S700_800 11.11 killall(1M) patch

IMPORTANT: For the most up-to-date required patches, refer to the PPU Installation page on the HP web site http://www.hp.com/go/softwaredepot (search for “T2351AA”).

HP-UX 11i v2 Requirements

For PPU Versions 8.x on
HP-UX 11i v2

The following software is required for PPU 8.x on HP-UX 11i v2:

  • HP-UX 11i v2 June 2006 update, or later

  • PPU software bundle T2351AA (version B.11.23.08.00.01) located on the following HP web site (search for “T2351AA”):
    http://www.hp.com/go/softwaredepot

  • WBEM software bundle B8465BA (version A.01.05 or higher, or version A.02.00 or higher for PA-RISC systems)

  • NParProvider bundle (version B.23.01.06.01 or higher, available from the OE)

  • The kernel configuration must include the diag2 module

  • Network access to utility meter software version 7.3 (or higher)

  • If you have a virtual partitioned environment, the Virtual Partitions software (bundle T1335BC) must be version A.04.01 or greater

NOTE: Updated firmware may be required by the NPar software, or by VPars software if you are using virtual partitions. Please check the product-specific documentation for additional requirements.

Your PPU system is shipped with the correct version of HP-UX and the PPU software bundle. If your system’s operating system is reinstalled with Ignite-UX, ensure that the correct version of HP-UX is used and the PPU software is reinstalled. See “Getting Started” for details.

Required Patches for HP-UX 11i v2

No patches are known for HP-UX 11i v2 systems at the time of publication of this document.

Upgrading PPU Software (HP-UX)

You can easily upgrade the PPU software from versions 5.x, 6.x and 7.x to version 8.x. If you are running PPU version 4.x, the upgrade to version 8.x requires a utility meter. If you want to upgrade from PPU version 4.x to version 8.x, you can utilize an existing utility meter, or order a utility meter from HP. Contact your HP sales representative if you have questions about upgrading PPU software.

OpenVMS 8.3 Requirements

For PPU Versions 8.x on
OpenVMS 8.3

The following software is required for PPU versions 8.x on OpenVMS 8.3:

  • hp OpenVMS Industry Standard 64 Operating System V8.3, or later

  • PPU software bundle BA485AA (versions 8.x) — installed from the OpenVMS I64 8.3 OE DVD

  • WBEMCIM bundle (version A2.0-A051013F or higher) — optionally installed with OpenVMS 8.3

  • Network access to utility meter software version 7.3 (or higher)

Windows Server 2003 Requirements

For PPU Versions 7.1 on
Windows Server 2003

The following software is required for PPU 7.1 on Windows Server 2003:

  • Windows Server 2003, 64-bit
    (either Enterprise or Datacenter edition)

  • WMI nPar Provider, 64-bit, version 2.0 or higher

  • WMI Mapper for Windows Server 2003 64-bit Edition, version 2.0 or higher

  • Baseboard Management Controller Driver (required by WMI nPar Provider), version 7.2.3790.3 or higher

  • Windows PPU installer cp006445.exe

  • Network access to a utility meter (version 7.3 or higher)

IMPORTANT: Windows PPU is only supported with the latest firmware, available on the Smart Setup media associated with HP Integrity Servers for Microsoft Windows Server 2003 64-bit version, Installer Media 4.5 or higher.

PPU is supported on Windows Server 2003 64-bit version, when hyperthreading is disabled. When hyperthreading is enabled and active, PPU does not report the correct usage information.

PPU is not supported on Windows Server 2003 64-bit version if it is running as an HPVM virtual machine (VM guest). PPU is supported on Windows Server 2003 64-bit version if it is running as an HPVM host. However, PPU does not report additional core usage information for the HPVM virtual machine (VM guest).

Your PPU system is shipped with the correct version of Windows Server 2003 and the PPU software. If your system’s operating system is reinstalled, ensure that the correct version of Windows, the PPU software, and other required components are used. See “Getting Started” for details.

OS Updates for Windows Server 2003

No OS updates are known to be required at the time of publication of this document. The latest version of this document can be found online at: http://docs.hp.com. Future updates, including firmware, drivers and documentation can be found at http://www.hp.com/support/itaniumservers.