HP OpenVMS Systems Documentation

Content starts here HP DECwindows Motif for OpenVMS Alpha

HP DECwindows Motif
for OpenVMS Alpha
New Features

Previous Contents Index Running the Color Customizer

To run the color customizer, perform the following steps:

  1. Copy the files CUSTOM.UID and CUSTOM.EXE, which were created during the customizer build, to the directory where the customizer will be run. A typical location is the directory SYS$LOGIN or the directory DECW$USER_DEFAULTS.
  2. Copy the files CUSTOM.DAT and DXMDEFAULTS.DAT from the directory DECW$EXAMPLES to the directory DECW$USER_DEFAULTS.
  3. Run the executable file CUSTOM.EXE as follows:



Only the colors of applications invoked after the customizer starts will be affected. For this reason, start the customizer as the first X application during the login process. Modifying the DECW$LOGIN.COM File

As noted in Section, the color customizer should be the first X application started during the login process. Do this by starting it as a subprocess from within the DECW$LOGIN.COM file. Add a command to wait approximately 10 seconds between customizer startup and the startup of other applications.

For example, add the following lines to the DECW$LOGIN.COM file:

$! Starting the color customizer
$ WAIT 0:0:10

See Using DECwindows Motif for OpenVMS and Managing DECwindows Motif for OpenVMS Systems for more information on the file DECW$LOGIN.COM. Command Interface Summary

A box containing a list of available palettes is in the leftmost section of the Color Customizer window. Click on the desired palette to see the colors take affect.

Below the palettes are two arrays of colored buttons, representing the dynamically allocated color cells for normal and shadow colors. To find out what resources are affected by a color cell, click and hold the arrow button next to the color cell.


As a shortcut, you can click on the screen facsimile in the rightmost corner of the dialog box. If the portion you click on is colored by one of the resource values controlled by the customizer, the pop-up window for the appropriate color button is displayed.

To modify a single color cell, click on the corresponding color button. A colormix widget pops up; as you modify the color, these modifications are reflected in your workstation environment. Use the colormix widget reset button to return to the starting color at any time. You can also change the color cell you are modifying by clicking on a different color button while the colormix widget is displayed.

The automatic shadowing option causes shadow and select colors to be automatically updated when their corresponding background colors are changed. The standard Motif shadowing algorithms are used for these calculations.

Use the File menu to modify, add, and delete color palettes as follows:

  • To modify an existing palette, select the palette, change the colors, and choose Save Palette from the File menu.
  • To add a new palette, select an existing palette, modify the colors as necessary, and choose Save Palette As... from the File menu. A message box prompts you for the name of the new palette.
  • To delete a palette, select the palette and choose Delete Palette from the File menu.

Changes made through the File menu automatically update the CUSTOM.DAT file, which contains the resource defaults.

The File menu Exit button causes the customizer application to exit. A warning dialog is displayed first. Note that the color cells allocated by the customizer (and used by the currently running applications) will be deallocated. After the customizer exits, if the colors of the currently running applications are not correct, the applications should be restarted to restore normal colors. Usually, there is no need to exit the color customizer; it is typically kept running at all times, like the Session Manager. Changing the Mapping Between Color Resources and Color Cells

The file DXMDEFAULTS.DAT allows you to control how many dynamic color cells are allocated and what resources are affected. This file contains resource specifications like the following:

*background:       DXmDynamicWindowBackground
*foreground:       DXmDynamicWindowForeground
*topShadowColor:   DXmDynamicWindowTopShadow

When the customizer is started, the file DXMDEFAULTS.DAT is written to a property on the root window. Any application that is subsequently run and that uses the correct X Toolkit Library merges these resources with its normal resource database. Resource specifications in this file take precedence over specifications with equivalent resource names in other resource default files.

The resource values within the file DXMDEFAULTS.DAT have a special format. For each unique color value in this file that begins with the string "DXmDynamic", a color button is created in the color customizer. If the string "Shadow" is encountered in a name, the color button is placed in the shadow button box rather than the normal color button box. If a color value string ends with the suffix "Background", it is linked to any color buttons with identical prefixes and suffixes of "TopShadow", "BottomShadow", or "SelectColor" for purposes of automatic shadowing. If a color value named "DXmDynamicScreenBackground" is encountered, the color cell allocated is used by the customizer to set the root window background color.

You can edit the file DXMDEFAULTS.DAT and define resources to use the same color cells. You can have separate dynamic color cells, for scrollbar widgets or for your DECwindows Mail application, for example, by adding the following lines to the file DXMDEFAULTS.DAT:

Mail*background:         DXmDynamicMyMailBackground
Mail*foreground:         DXmDynamicMyMailForeground
Mail*topShadowColor:     DXmDynamicMyMailTopShadow
Mail*bottomShadowColor:  DXmDynamicMyMailBottomShadow

Adding the previous lines to the file DXMDEFAULTS.DAT and restarting the customizer causes four new color cells to be allocated and four new color buttons to be added to the customizer interface. These buttons are assigned default color values (usually black or white) for each palette. These defaults can then be modified for each palette through the customizer interface.


The text of the DXMDEFAULTS.DAT file is read and parsed by the color customizer. The parsing algorithm does not allow comments, incorrect spacing, or incorrect resource specifications. If this file or the CUSTOM.DAT resource file become corrupt, the customizer cannot start correctly. To resolve the problem, copy the versions of CUSTOM.DAT and DXMDEFAULTS.DAT from the DECW$EXAMPLES directory into your login directory. Using the Customizer with DECterm Windows

To change the colors of DECterm windows, copy the DECterm resource specifications from the file DXMDEFAULTS.DAT and add them to the DECterm resource defaults file DECW$USER_DEFAULTS:DECW$TERMINAL_DEFAULT.DAT. For example, add the following lines to the DECterm resource defaults file:

  DECW$TERMINAL.main.terminal.background: DXmDynamicTerminalBackground
  DECW$TERMINAL.main.terminal.foreground: DXmDynamicTerminalForeground

This allows the DECterm window colors to be customized with the color customizer. Changing the Default Value of the Automatic Shadowing Toggle Button

The default value of the automatic shadowing toggle button is set using the Custom.autoShadow resource in the CUSTOM.DAT file as follows:

Custom.autoShadowing: False

The default value is True. Using the Customizer on Multihead Systems

The color customizer affects only applications started on the same screen as the customizer. On most multihead systems, you can start a different color customizer for each screen and have a different palette in effect on each screen. On multihead systems using XINERAMA, a single instance of the color customizer affects all applications, since the screens function as a single logical screen.

The color customizer can be configured so that it is invoked once and affects all applications regardless of where they are started. This mode is invoked by modifying the Custom.multiScreen resource in the CUSTOM.DAT file as follows:

Custom.multiScreen: True

The default value is False. Using the XSETROOT_CUST.EXE Demonstration Program

The XSETROOT_CUST.EXE demonstration program, created during the customizer build, is a modified version of the MIT utility program xsetroot that is used to set a bitmap on the root window. The XSETROOT_CUST.EXE program uses DXmDynamicScreenBackground and DXmDynamicScreenForeground as the background and foreground colors of the specified bitmap. If your DXMDEFAULTS.DAT file contains entries for these two dynamic colors, then use the customizer to dynamically modify the colors of your bitmap.

For example:


2.2.3 Drag and Drop Support


The drag-and-drop feature lets you move or copy screen objects. This feature is provided primarily for programmers who choose to incorporate drag-and-drop into their applications. For example, you can move text from a text entry area and paste it elsewhere.

All DECwindows Motif applications except Notepad support the drag-and-drop feature. DECwindows Mail supports the drag-and-drop feature in all windows except the main message area, where DECwindows Mail has its own drag-and-drop; you can use MB2 to move messages around with the SVN interface.

To drag and drop text into a new location:

  1. Select the text to be copied or moved with MB1.
  2. To move the text, press and hold MB2; to copy the text, press and hold Ctrl/MB2.
    A move or copy icon appears.
  3. Drag the icon to the location where you want to drop the text and release MB2.
    If the object is highlighted as you drag the icon across it, you can drop the text into that location.

For a list of the widgets that support drag-and-drop functionality, see Section 4.7.1.

2.2.4 Tear-Off Menu Support


Most DECwindows Motif applications allow you to tear off pull-down and popup menus. Tear-off menus let you keep frequently used menus displayed without repeatedly pulling them down or popping them up.

To tear off a menu:

  1. Display a pull-down or popup menu.
    If the menu is a tear-off menu, a dotted line is displayed at the top of the menu.
  2. Click on the dotted line with MB1.
    The menu remains active until it is closed or until the parent application is closed.

To close a tear-off menu:

  1. Click on the Window menu button in the tear-off menu.
  2. Choose the Close menu item.

2.3 New Desktop Environment

This section describes new features related to the New Desktop environment.

2.3.1 Support for UNIX-Style Filenames


Starting with DECwindows Motif for OpenVMS Alpha Version 1.3, you have the ability to display file and device names in UNIX-style format in the File Selection widget and the File Manager (DTFILE).

When this feature is enabled, file and directory specifications are displayed according to UNIX pathname conventions, such as using slashes instead of square brackets to delimit directory trees. In addition, the case of device names is preserved when displaying UNIX-style pathnames versus being converted to uppercase.

The following sections briefly describe how to enable this feature. Enabling in the File Selection Dialog Box

To enable the display of UNIX-style filenames in the File Selection dialog box, set one or more of the following logicals to a non-zero value:


These logicals can be defined system-wide by adding them to the SYS$MANAGER:SYLOGICALS.COM file, or defined on a per-user basis by adding them to each user's DECW$LOGIN.COM or LOGIN.COM file.

To force the File Selection dialog box to return selected filenames in OpenVMS format while displaying them in UNIX format, define the logical DECW$XM_UNIX_NAMES_TO_VMS. This enables other applications that rely on filenames in OpenVMS format to interact successfully with the File Selection dialog box while still displaying filenames in UNIX format. Enabling in the File Manager (DTFILE)

To enable the display of UNIX-style filenames in the File Manager (DTFILE) set the logical CDE$DTFILE_UNIX_NAMES to a non-zero value.

This logical can be defined system-wide by adding it to the SYS$MANAGER:SYLOGICALS.COM file, or defined on a per-user basis by adding it to each user's DECW$LOGIN.COM or LOGIN.COM file.

2.3.2 Screen Saver and Screen Lock Support


New Desktop now supports the MIT Screen Saver extension (MIT-SCREEN-SAVER), which is available on systems running on OpenVMS Alpha Version 7.1 or greater. This extension enables you to use the following features, which are available from the Style Manager Screen dialog box:

  • Screen saver---Prevents screen burn-in by displaying one or more screen savers after a specific timeout period. You can set both the timeout period and the amount of time each screen saver is displayed onscreen.
    Sample screen savers are available from CDE$SYSTEM_DEFAULTS:[EXAMPLES.DTSCREEN]. To learn how to create additional screen savers and make them available to the Style Manager, see Getting Started With the New Desktop.
  • Screen lock---Secures your current New Desktop session(s) by locking the Front Panel after a specific timeout period. Once locked, a user must enter the account password of the current session to unlock the desktop.

Note that these features are enabled at initial DECwindows Motif startup. You can disable the screen saver and screen lock functions from the Style Manager application.

For more information on using screen saver and screen lock, see the online help for the Style Manager application.

2.3.3 Updated Welcome Message


The welcome message in the Login Screen now displays a host name regardless of the transport. If the DECnet transport is configured, the DECnet host name is displayed. If the TCP/IP transport is configured, the TCP/IP host name is displayed. If neither transport is configured, a default message of "Welcome to OpenVMS" is displayed.

2.3.4 Selecting Screens on Application Launch


You can graphically select the screen on which a new application is displayed when launched from either the Front Panel, the File Manager, or the Application Manager. By default, the new application appears on the current screen (that is, the screen containing the mouse pointer). The feature allows you to drop an application icon from the File Manager or Application Manager onto one of the numbered screen controls of the Set Default Screen window. This starts the application on the selected screen without changing the current screen.

The Set Default Screen window is activated by selecting the "Set Default Screen" application in the Application Manager's Desktop Tools folder. You can start a separate instance of the Set Default Screen window on each screen. The highlighting of the default screen is synchronized across all instances of the Set Default Screen window.

2.3.5 Front Panel Icons Support MB3 Operations


The New Desktop Front Panel supports mouse button 3 (MB3) operations. When the cursor is placed over a Front Panel icon and you press MB3, a subpanel or menu appears. The menu items are as follows:

  • Top item--The label of the menu.
  • Second item--The application that starts if you single click on the icon.
  • Third item--Add or delete a subpanel, depending on whether a subpanel already exists for the control panel.


    If the third item is "Delete Subpanel", this change is difficult to reverse without reinstalling the kit.

2.3.6 Detached Processes


When you start an application (from the Front Panel or dtfile), a new detached process is created with a process name constructed from the user name, $CDE, and a three-digit numeric identifier.

For example, user SMITH starts an application whose process name is SMITH$CDE001. The next assigned process name would be SMITH$CDE002, unless SMITH$CDE001 has already terminated and is available for reuse.

2.3.7 Viewing Reference Pages


DECwindows contains a collection of help files for the New Desktop called reference pages (also known as manpages). Reference pages are divided into sections and, on OpenVMS, the file extension indicates the section. Sections distributed with the release include the following:

Section Purpose Extension
1 Applications filename.1
3 Libraries/programming filename.3
4 Programming filename.4
5 Include file formats filename.5

A version of dthelpview has been set up with the appropriate action definition for manpage viewing. The process logical MANPATH has been defined to point to the CDE$SYSTEM_DEFAULTS:[MAN] directory that contains all of the reference page files.

You can use either of the following methods to start dthelpview and display reference pages:

Method 1

To start dthelpview from DECterm and view a reference page called dtaction.1:

  1. At the DCL level or in a LOGIN.COM file, define dthelpview as a foreign command by entering the following:

    $ dthelpview :== -
    _"$ sys$sysdevice:[sys0.syscommon.cde$defaults.system.bin]dthelpview.exe"
  2. At the DCL level, enter:

    $ dthelpview -"manPage" dtaction.1

Method 2

To start dthelpview from Application Manager and view the reference page called dtaction.1:

  1. Start Application Manager.
  2. Double click on the Man Page Viewer icon located in the Desktop Apps application group. A dialog box appears.
  3. Enter the reference page to be viewed and click on OK.

2.4 Traditional Desktop Environment

This section describes new features related to the traditional DECwindows desktop environment.

2.4.1 Resource Added for DECwindows XUI Applications


The resource Mwm*useDECMode has been added to allow previous versions of DECwindows XUI applications to behave correctly with the Motif Window Manager. In particular, this resource is used to control focus, window placement, multiline icons, and the window's initial state (normal or minimized).

2.5 Applications

The following sections describe new features related to specific DECwindows Motif applications.

2.5.1 Bookreader

This section describes features related to the Bookreader application. Bookreader Printing Improved


The Bookreader application allows only draft-quality printing for books or topics. However, the Bookreader print function has been improved to eliminate such problems as missing lines and words, figures being overwritten by text, and poor leading of lines.

2.5.2 CDA Viewer

This section describes features related to the Compound Document Architecture (CDA) Viewer application. Using the CDA Viewer to View Asian-Language Text


You can use the CDA Viewer in two ways to view text files that contain Asian characters:

  • Specify an options file to the CDA Viewer application.
  • Define logical names at the DCL command level or in a LOGIN.COM file.

Refer to the DECwindows Motif for OpenVMS Applications Guide for information about using the CDA Viewer. Specifying an Options File

Specify an options file by including a one-line entry in the file in the following format:

TEXT TEXT_ENCODING text_encoding_value
  • TEXT is the format.
  • TEXT_ENCODING is the option you specify to CDA.
  • text_encoding_value is the value of the codeset. (See Table 2-2 for a list of values.)

Table 2-2 shows the languages, codesets, and text-encoding values.

Table 2-2 Asian Language Codes for Options Files
Language Codeset Text Encoding Value
Japanese DEC Kanji DEC_KANJI
Japanese Super DEC Kanji SDECKANJI
Traditional Chinese DEC Hanyu DEC_HANYU
Simplified Chinese DEC Hanzi DEC_HANZI
Korean DEC Korean DEC_HANGUL

The following table shows examples of one-line entries.

Options File One-Line Entry

To view the EXAMPLES_CUSTOMERS.TXT file that contains Japanese text in DEC Kanji, use your editor to create an options file called KANJI.CDA$OPTIONS. Add the following one-line entry to the file:


When you access the file through the Options File dialog box with the CDA Viewer, the EXAMPLES_CUSTOMERS.TXT file is viewable in the DEC Kanji codeset (Japanese language).

Previous Next Contents Index